Reference our supported devices list here. If your device is not on this list, don't give up hope! It may work, but this list is guaranteed to be compatible.

Our devices require BLE (Bluetooth low energy a.k.a Bluetooth 4.0) to connect to the app. BLE is only available in certain operating systems and phones. (Android users: the following app will allow you to confirm if your phone/tablet possesses BLE - https://play.google.com/store/apps/details?id=com.magicalboy.btd&hl=en)

 

iOS requires version 8 and higher (iPhone 4 excluded due to BLE requirement)

Android requires version 4.4 and higher 

 

Your phone must have at least a 4 inch display as well, measured from the bottom left corner of the screen to the top right corner.

 

Please note, the Fusion Lite does not sync with a computer. You must have a smartphone or select tablet to use it.