The Fusion Lite will not sync with a computer or online dashboard.

 

The Fusion Lite must be connected with a phone/tablet which possesses BLE (Bluetooth low energy a.k.a Bluetooth 4.0) technology. BLE is only available in certain operating systems and phones. (Android users: the following app will allow you to confirm your phone/tablet possesses BLE - https://play.google.com/store/apps/details?id=com.magicalboy.btd&hl=en)


See our current list of supported devices here. If your phone/tablet is not on our list, don't worry! You may still be able to connect with the Fusion Lite using the Striiv Activity Tracker app if your phone/tablet has BLE and meets the requirements below. 


iOS requires version 8.1 and higher (iPhone 4 excluded due to BLE requirement)

Android requires version 4.4 and higher 


All phones must have at least a 4 inch screen, measured from the bottom left of the screen to the top right.